Trip Logs & GPS issues

Questions and discussions about the setup and installation of Tru-Traffic

Moderator: bullock

Trip Logs & GPS issues

Postby AnnePlatt » Mon Oct 31, 2016 6:40 pm

Hi there,

We have two tablets running Tru-Traffic (a Trimble YUMA 2) and a Panasonic Toughpad. Recently we have gotten an error saying "the data stream from the GPS receiver was interrupted. Make sure the data cable is securely connected to your computer and GPS receiver and the power to the GPS receiver is reliable" and it stops logging our trip. We have been running the Trimble tablet with Tru-traffic for a while now with no problems until last week when this error started coming up.

Do you have an suggestion of what to do about this? Both tablets are using internal GPS.

Thank you!

Andrea
Regional Municipality of Durham
AnnePlatt
 
Posts: 10
Joined: Tue Sep 28, 2010 6:46 pm
Location: Whitby, Ontario

Re: Trip Logs & GPS issues

Postby bullock » Mon Oct 31, 2016 8:06 pm

Sorry for the trouble, Anne.

This message appears when the time gap between successive GPS reports exceeds a user-settable value.

That you're getting the message now suggests that either
  1. The user-settable value is too low for this particular GPS receiver (and maybe too low for any GPS receiver),
  2. The GPS receiver is set to report too infrequently, or
  3. The GPS receiver reports only when significant changes in location or velocity occur, and in your recent trips, these didn't change frequently enough to satisfy Tru-Traffic.

Let's start with the user-settable value in Tru-Traffic. You'll find it under View: GPS View: Options: Trip Log Recording. What is the value set for "Tolerate interruptions from the GPS data stream of up to" ? The default is 20s, if I remember correctly. If it's set to less than, say, 7s, then it might suffice to increase the value (to, say, 20s). If it's already 20s or so, then it still may help to increase the value, but we'll probably want to look deeper as well.

Does your GPS devices allow you to view (and specify) the rules under which it reports the location & speed? If so, then what rule(s) is it using?

I think the ideal rule is to report at regular time intervals of one or two seconds. Set it to that, if you can.

Some devices report only when the location changes by a specific distance. This can cause problems for us (and for Tru-Traffic). A minor problem is that you get no report while waiting in a queue, and it might trigger the error message that you saw. You can avert this nuisance by increasing Tru-Traffic's patience to something longer than the time you expect to wait in a queue -- say 120s. The more serious problem is that Tru-Traffic can't be sure of the time and location of a "stop", or it can even miss a stop altogether. The GPS might report as the vehicle is slowing (but before it comes to a stop), and it's next report might be while the vehicle is accelerating, downstream from the stop location. In this case, Tru-Traffic cannot determine accurately the time or duration or location of the stop, and if the vehicle happened to be moving faster than Tru-Traffic's stop threshold (15 mph, by default) then it won't even detect the stop (since it uses instantaneous speed, not time & distance, to detect stops.

Some devices report only when the heading (or maybe the speed) changes by a significant amount. As long as you're heading in a straight line, it won't give any updates. This is a bigger problem for Tru-Traffic, causing the "stop" ambiguity described above as well as other problems.

If the problem is with the rules settings on your device, but it doesn't let you specify updates every 1 or 2 seconds, then please let me know what options it offers and maybe we can come up with something adequate.

Regards.
Greg
bullock
Site Admin
 
Posts: 204
Joined: Thu May 06, 2004 6:51 pm
Location: Pacific Grove, CA

Re: Trip Logs & GPS issues

Postby AnnePlatt » Tue Nov 01, 2016 5:28 pm

Hi Greg,

Thank you for your quick reply. I will check into the GPS settings and get back to you shortly.

Thanks,

Andrea
AnnePlatt
 
Posts: 10
Joined: Tue Sep 28, 2010 6:46 pm
Location: Whitby, Ontario


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron