User vs computer install

Questions and discussions about the setup and installation of Tru-Traffic

Moderator: bullock

User vs computer install

Postby TerraEng » Thu Dec 11, 2014 3:56 pm

I wanted to ensure that I am not just having issues with my install. When the program is installed on a Windows 7 computer under the administrator login - is it ONLY available under this one user? That would mean that licensing of the software is on a user basis not a computer basis.

I just want to confirm so I can figure out how to allow multiple users to use the program at different times.

Thanks

Bob
TerraEng
 
Posts: 1
Joined: Thu Dec 11, 2014 3:03 pm

Re: User vs computer install

Postby bullock » Thu Dec 11, 2014 5:11 pm

If you both, install the software and enter the license, using the administrator login, then it should get installed for, and licensed to, all users on that machine.

There are two stages here that would require the administrator privileges.
  1. Running the Setup to install the software, and
  2. Running the software the first time to enter the license information (in Help: About: License).

In the first stage, if you login with administrator privileges, then it should install in "C:\Program Files (x86)" and be available to all users. If instead you login as an unprivileged user, it will install in your personal folder "C:\Users\<username>\AppData\Local\Programs", and be available only to you (and any other users would have to separately install in their personal folders).

In the second stage, if you run the software and enter the license information with administrator privileges, then it should store the license in the Local _Machine area of the registry and be available to all users. If instead you login as an unprivileged user to enter the license information, it will store in your Current_User area of the registry, and it will be licensed only to you. Any other users would have to separately enter the license information.

If that doesn't work as hoped, then please let me know.
bullock
Site Admin
 
Posts: 206
Joined: Thu May 06, 2004 6:51 pm
Location: Pacific Grove, CA

Re: User vs computer install

Postby AnnePlatt » Fri Dec 01, 2017 4:31 pm

Hi Greg,

We have recently increased the number of tablets available to us for doing speed-delay trips using Tru-Traffic. We went from sharing 1 to having 3 now!

I made the mistake though of installing and activating 2 licenses for the software with my login instead of administrative login :(

How can I undo it and re-assign the license?

Thanks for your help,

Andrea Platt
Regional Municipality of Durham
Ontario, Canada
AnnePlatt
 
Posts: 12
Joined: Tue Sep 28, 2010 6:46 pm
Location: Whitby, Ontario

Re: User vs computer install

Postby bullock » Fri Dec 01, 2017 10:10 pm

Hi, Andrea.

If you now enter, or re-enter the license information with your administrative login, then I think it will ignore the license information associated with your unprivileged login and use only the administrative license information. That might suffice for your needs.

If that's not enough (either because I mis-remember which license information gets priority or because you need to remove the the unprivileged login license for other reasons), then you can try just run the software with your unprivileged login and delete the license entries, leaving empty boxes. It that works as I hope, then thereafter the administrative login license will appear and have priority.

Let me know if these don't fix all the problems. In that case, I'll need to walk you through some Registry surgery.

Regards.
Greg
bullock
Site Admin
 
Posts: 206
Joined: Thu May 06, 2004 6:51 pm
Location: Pacific Grove, CA

Re: User vs computer install

Postby AnnePlatt » Mon Dec 04, 2017 8:05 pm

Thanks for your help Greg.

I did what you suggested with clearing the license info under my login and logging in as an admin and re-entering it. I found that any other user that logs in just has the re-enter the same license key originally input (as admin) and it works.

Thanks again for your helpfulness!
AnnePlatt
 
Posts: 12
Joined: Tue Sep 28, 2010 6:46 pm
Location: Whitby, Ontario


Return to Installation

Who is online

Users browsing this forum: No registered users and 1 guest

cron